GWcode SyntaxHighlighter Support


Avatar for Hasco Ulijn

#1 By Hasco Ulijn @ March 24th, 2011 14:55 (79 months ago)

Hi, i'm working with GWcode on a recent project where i run into one problem, I'm using Wygwam 2.2.3 and everytime when I make a correction no matter what in a entry where the GWcode Wygwam fields are used and I submit this change the code get partially parsed in browsers..

The GWcode wygwam is being used in a Matrix, could there be the problem?
Or is it that it's best compatible with Wygwam 2.0.1?

Kind regards,

Hasco Ulijn

Avatar for Leon Dijk

Author

#2 By Leon Dijk @ March 24th, 2011 19:47 (79 months ago)

Hi Hasco,

It should be compatible with Wygwam 2.0.1 or above. There was a bug in Wygwam 2.2.1 that caused a problem with GWcode SyntaxHighlighter, but Brandon released the 2.2.2 version shortly after that to fix it. I'm using 2.2.2 myself and it works fine here.

Did you follow the instructions in point 6 of the installation instructions?
http://gwcode.com/add-ons/gwcode-syntaxhighlighter/installation

I think that might be the cause of your problem. Let me know if that solves it or not!

Thanks,
Leon

Avatar for Hasco Ulijn

#3 By Hasco Ulijn @ March 24th, 2011 20:18 (79 months ago)

Hi Leon,

Thanks for your response! As far as I know I've covered that part of the installation, I'm free at the moment til Monday and I'll do a fresh installation then just to be shure and I will certainly let you know if it is solved by then or not!

thanks in advance,
Hasco

Avatar for Leon Dijk

Author

#4 By Leon Dijk @ March 25th, 2011 20:55 (79 months ago)

Hi Hasco,

I've upgraded my Wygwam to version 2.2.3 and it's working fine, so I'm fairly certain you're missing that particular setting. Let me know if that was the problem or not!

Cheers,
Leon

Avatar for Hasco Ulijn

#5 By Hasco Ulijn @ April 19th, 2011 09:42 (79 months ago)

Hi Leon,

Sorry it's been a while, I finally came around to get back at the project and it took some figuring out, but final conclusion is that the Matrix is the problem. Matrix automatically parses ExpressionEngine tags even if you don't want them to, it would have been nice to use the GWcode inside a Matrix so you can put multiple lines of code as in alineas inside one entry, but we'll work around that for the time being. I want to thank you for your support and maybe you can do something somtime with that GWcode meets Matrix issue ;)

I'll let you know when the project is finished so you can see your creating at work :), should be around the start of May!

Cheers,
Hasco

Avatar for Leon Dijk

Author

#6 By Leon Dijk @ April 19th, 2011 21:42 (78 months ago)

Wow thanks Hasco, for tracking down the problem and for getting back to report it! I'll definitely take a look when I have some time to see of I can make it matrix compatible. Do post the project when it's done, would love to see the result!

Avatar for Sean

#7 By Sean @ June 03rd, 2012 17:51 (65 months ago)

Have just posted up a support request here: http://devot-ee.com/add-ons/support/gwcode-syntaxhighlighter/viewthread/6042 with as much detail as I could think of.

Submit your comment

(Required)
(Required, will not be published)
(Optional)

Need to Post HTML Code?
- Use Postable to convert HTML to entities.
- Copy/paste Postable code in between <pre><code></code></pre> tags.

Remember my information
Send me an email when new comments are added